Archived Support Site

This support site is archived. You can view the old support discussions but you cannot post new discussions.

Draft Previews

justin's Avatar

justin

21 Jan, 2015 09:46 PM

I am having a problem with using the preview feature with Better Workflow. The part that puzzles me the most is that it is not consistent. First the versions, etc.:

EE 2.8.1
BWF 1.6.4.2
Structure 3.3.14
Content Elements 1.7.0
Wygwam 3.3.1

There are 6 channels that use BWF for drafts and previews. Of those, 2 channels work flawlessly, 3 channels give me the bad-preview.jpg screen, and 1 shows the preview but doesn't show all of the fields that are in the template. The channels that have the bad-preview show up if using the shared preview URL, but also do not show all of the fields.

I changed the settings in BWF so that each channel had a separate preview template ignoring structure urls, etc.(extension-settings.jpg), but had all the same results. I then thought it may have been something to do with the Content Elements fieldtype since it was one of the fields not showing content. However, one of the other channels that works flawlessly also has a content elements field. I truly am stumped on this one. Can you give me some direction?

I also just got a report that the "Publishers" (extension-settings.jpg) are not receiving notifications when an entry is submitted for review. The state of the entry seems correct for the editor that submitted the changes.

  1. Support Staff 1 Posted by Malcolm Elswort... on 23 Jan, 2015 01:25 PM

    Malcolm Elsworth's Avatar

    Hi Justin,

    If the preview works sometimes and not other I could check your templates. BWF stores it data differently from regular EE entries so you have to write conditionals differently. For example:

    {if '{your_var}' != ''}
    

    And not

    {if your_var}
    

    I would strip the templates down to the most basic code and get it working. Then build it back up bit by bit.

    Hope that helps.
    Malcolm

  2. 2 Posted by justin on 23 Jan, 2015 02:46 PM

    justin's Avatar

    I had done some closer comparisons with the templates, and it turned out
    that one of the fields that had the problem was in fact a conditional
    statement that wasn't present in one of the other templates using that
    field type.

    The other problem was a data-related one. Thanks for your help and
    getting me looking for the right thing!

  3. Support Staff 3 Posted by Malcolm Elswort... on 23 Jan, 2015 05:02 PM

    Malcolm Elsworth's Avatar

    Glad we got it resolved.

    Have a good weekend.

  4. Malcolm Elsworth closed this discussion on 23 Jan, 2015 05:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac