Archived Support Site

This support site is archived. You can view the old support discussions but you cannot post new discussions.

Preview issue with Disqus

jim's Avatar

jim

10 Feb, 2014 05:11 PM

Hi,

We are experiencing a problem with Disqus commenting when users preview an entry prior to publishing. When previewing ahead of time it shows the wrong comments. If we don't preview it works fine. I think it has to do with the fact that the preview url is different than the live url as shown in the thread below--the preview url uses the entry_id. Have you seen this? Any way around this?

http://help.disqus.com/customer/portal/articles/735138-why-are-the-...

Thanks,

Jim

  1. Support Staff 1 Posted by Malcolm Elswort... on 11 Feb, 2014 11:19 AM

    Malcolm Elsworth's Avatar

    Hi Jim,

    This is not something we have encountered and seems to be related to the way Disqus uses a page's URL as a unique identifier.

    BWF uses the standard EE template_group/template/entry_title (or ID) for previewing. If you are using Structure or Pages and have different URLs I can see this could cause the issue above.

    One option could be to hide Disqus while previewing. You can do this using the {is_bwf_preview} BWF template tag.

    Best wishes,
    Malcolm

  2. Malcolm Elsworth closed this discussion on 11 Feb, 2014 11:19 AM.

  3. Malcolm Elsworth re-opened this discussion on 11 Feb, 2014 11:20 AM

  4. Support Staff 2 Posted by Malcolm Elswort... on 11 Feb, 2014 11:20 AM

    Malcolm Elsworth's Avatar

    Sorry, didn't mean to close this when I posted that comment.

  5. 3 Posted by jim on 11 Feb, 2014 01:48 PM

    jim's Avatar

    I think I've got it figured out.

    Thanks.

    Jim

    Sent from my iPhone

  6. Rob Hodges closed this discussion on 12 Feb, 2014 03:29 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac