Archived Support Site

This support site is archived. You can view the old support discussions but you cannot post new discussions.

Publisher workflow role for Superadmin but without getting notifications

emily's Avatar


29 Nov, 2011 11:24 AM

I am Superadmin and I am set up as a Publisher in the Workflow roles so that I can test the system. My client is in what I've called a Publisher member group which is set up as a Publisher in the Workflow roles too. She wants to receive the 'submitted for approval' notifications and I don't.

It would be great if there were Publisher (with notifications) and Publisher (without notifications) types for the Workflow roles.

Obviously I can just set up a rule to delete them in the meantime but maybe you'll consider adding this in.


  1. 1 Posted by Rob Hodges on 29 Nov, 2011 11:27 AM

    Rob Hodges's Avatar

    Hi Emily,

    Hm, I thought they were only sent to the 'selected' notification grp for each channel. Are you saying that this option for example on the editorial channel is set to 'publisher'(in the dropdown) and you are getting notifications? (As a superadmin)



  2. 2 Posted by emily on 29 Nov, 2011 11:33 AM

    emily's Avatar


  3. 3 Posted by Rob Hodges on 29 Nov, 2011 11:34 AM

    Rob Hodges's Avatar

    We shall take a look forthwith!

  4. 4 Posted by Rob Hodges on 29 Nov, 2011 12:21 PM

    Rob Hodges's Avatar

    Hi Emily,

    We've tested this and cannot replicate it, as well as checking the code for this particular feature. Please can you switch on logging and try this again?

    Then open the log (system/expressionengine/third_party/ep_better_workflow/log/log.txt) and look for "notify_users" and just below you can see the email addresses the notifications are sent to.

    The log file gets massive very quickly so don't leave it on after :)



  5. Rob Hodges closed this discussion on 08 Dec, 2011 04:34 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac